Settlement Delay - Australia

Incident Report for Worldpay for platforms

Resolved

Thank you for your patience. This incident has been resolved. Settlements and Settlement Reports will be received today, before midnight tonight. We again apologise for any inconvenience this may have caused.
Posted Aug 04, 2026 - 10:30 UTC

Investigating

Please be advised that there has been a delay in the settlement of funds this morning - this issue is currently being investigated.

The Settlements will still occur today, however, they will be received later than usual. Due to this delay, the accompanying Settlement Reports will also be generated and received later than usual.

We apologise for any inconveniences caused by this.
Posted Aug 03, 2026 - 23:48 UTC
This incident affected: Reporting and Settlement.