Settlement Delays - Australia

Incident Report for Worldpay for platforms

Resolved

Thank you for your patience.

This incident has been resolved. Settlements and Settlement Reports will be received today.

We again apologise for any inconvenience this may have caused.
Posted May 19, 2025 - 02:57 UTC

Identified

We have been advised by our Sponsor Bank that unfortunately there has been a delay in settling funds this morning.

The issue is being investigated at the Bank’s end now. We have been advised that the Settlements will proceed to occur today, however they will be received later than usual. Due to this delay, the Settlement Reports will also be received later than usual.

We apologise for any inconveniences caused by this.
Posted May 19, 2025 - 01:51 UTC
This incident affected: Reporting and Settlement.